aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPhilippe Blain <levraiphilippeblain@gmail.com>2022-08-23 23:05:26 -0400
committerKonstantin Ryabitsev <konstantin@linuxfoundation.org>2022-08-24 10:00:52 -0400
commit65ba7a9d3ee989035a875e7c108f1733e92c7ea0 (patch)
tree2cdc5ecfe5cecc2d1eb330168b61846f2607e648 /setup.py
parente107170fc17e3e2effb6a1629a8658497f59375b (diff)
downloadb4-65ba7a9d3ee989035a875e7c108f1733e92c7ea0.tar.gz
setup.py: bump python_requires to 3.8
Since c95e4d1 (am: Fix broken guessbranch handling, 2022-03-31), b4 uses the 'extend' action for the '--guess-branch' argument. This action is new in Python 3.8 [1], but setup.py still lists Python 3.6 as the minimum version. This leads Pip to allow installing or upgrading b4 on Python 3.6 or 3.7, but then any invocation of b4 fails with an error from the argparse module ending with: ValueError: unknown action "extend" Fix this by bumping python_requires to 3.8. [1] https://docs.python.org/3/library/argparse.html#action Signed-off-by: Philippe Blain <levraiphilippeblain@gmail.com> Signed-off-by: Konstantin Ryabitsev <konstantin@linuxfoundation.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1565f30..458b135 100644
--- a/setup.py
+++ b/setup.py
@@ -46,7 +46,7 @@ setup(
'dkimpy>=1.0,<2.0',
'patatt>=0.5,<2.0',
],
- python_requires='>=3.6',
+ python_requires='>=3.8',
entry_points={
'console_scripts': [
'b4=b4.command:cmd'