summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKonstantin Ryabitsev <konstantin@linuxfoundation.org>2020-03-16 11:54:57 -0400
committerKonstantin Ryabitsev <konstantin@linuxfoundation.org>2020-03-16 11:55:59 -0400
commit9fbf26bbe089875ab88543c9043962d6d195a4f0 (patch)
tree1f5a32151ac6fadb45c2206ee01133683ffab738 /setup.py
parenta038fd7e12e6ca9cbb31e75d7ac63edb8a879f83 (diff)
downloadb4-9fbf26bbe089875ab88543c9043962d6d195a4f0.tar.gz
Add docs and manpages
This should be most of what's needed for the pip release. Signed-off-by: Konstantin Ryabitsev <konstantin@linuxfoundation.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 7 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index c8acc52..00e8d52 100644
--- a/setup.py
+++ b/setup.py
@@ -18,14 +18,19 @@ NAME = 'b4'
setup(
version=VERSION,
- url='https://git.kernel.org/pub/scm/devel/b4/b4.git',
+ url='https://git.kernel.org/pub/scm/utils/b4/b4.git',
name=NAME,
description='A tool to work with public-inbox and patch archives',
author='Konstantin Ryabitsev',
author_email='mricon@kernel.org',
packages=['b4'],
license='GPLv2+',
- #long_description=read('README.rst'),
+ long_description=read('man/b4.5.rst'),
+ long_description_content_type='text/x-rst',
+ keywords=['git', 'lore.kernel.org', 'patches'],
+ install_requires=[
+ 'requests'
+ ],
entry_points={
'console_scripts': [
'b4=b4.command:cmd'