summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKonstantin Ryabitsev <konstantin@linuxfoundation.org>2020-03-18 18:12:35 -0400
committerKonstantin Ryabitsev <konstantin@linuxfoundation.org>2020-03-18 18:12:35 -0400
commit71ba636c17343d81611eb244e6e3e7a610055fe7 (patch)
tree7b0cca0ba6a4fb1c6aa36cea7d80076113d789a0 /setup.py
parent8a0a359c76a25d74c3e2de6a350422ae9ca67798 (diff)
downloadb4-71ba636c17343d81611eb244e6e3e7a610055fe7.tar.gz
Use b4.VERSION for setup.py version info
No longer need to change version in both places. Signed-off-by: Konstantin Ryabitsev <konstantin@linuxfoundation.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1c9f6e1..5944988 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
#!/usr/bin/env python3
import os
+import b4
from setuptools import setup
# Utility function to read the README file.
@@ -13,11 +14,10 @@ def read(fname):
return open(os.path.join(os.path.dirname(__file__), fname)).read()
-VERSION = '0.3.3'
NAME = 'b4'
setup(
- version=VERSION,
+ version=b4.VERSION,
url='https://git.kernel.org/pub/scm/utils/b4/b4.git',
name=NAME,
description='A tool to work with public-inbox and patch archives',