aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKonstantin Ryabitsev <konstantin@linuxfoundation.org>2020-11-17 16:00:17 -0500
committerKonstantin Ryabitsev <konstantin@linuxfoundation.org>2020-11-17 16:00:17 -0500
commit791fb2c96794ea71a7e79b0c347b123f18defcce (patch)
treec9de46149603415354f72cf394be97c8a2d17c38 /setup.py
parentb1bf5f6fc8335b71d841ba8b82a3d771a8690ea1 (diff)
parentcc6bbbeb1c824da64a59fbd1a483c780bc121c3b (diff)
downloadb4-791fb2c96794ea71a7e79b0c347b123f18defcce.tar.gz
Merge branch 'levraiphilippeblain_gmail_com'
Incorporate patches from Philippe Blain. Signed-off-by: Konstantin Ryabitsev <konstantin@linuxfoundation.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ed24367..867b5cf 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,10 @@ NAME = 'b4'
setup(
version=find_version('b4/__init__.py'),
- url='https://git.kernel.org/pub/scm/utils/b4/b4.git',
+ url='https://git.kernel.org/pub/scm/utils/b4/b4.git/tree/README.rst',
+ project_urls={
+ 'Community': 'https://linux.kernel.org/g/tools'
+ },
name=NAME,
description='A tool to work with public-inbox and patch archives',
author='Konstantin Ryabitsev',
@@ -35,6 +38,7 @@ setup(
license='GPLv2+',
long_description=read('man/b4.5.rst'),
long_description_content_type='text/x-rst',
+ data_files = [('share/man/man5', ['man/b4.5'])],
keywords=['git', 'lore.kernel.org', 'patches'],
install_requires=[
'requests'